Some internet sites won't load.

0 votes
asked Oct 7, 2011 by Zorbeen98 (311 points)
All of a sudden SOME web pages won't load. Mega upload doesn't work. Nor does people's tumblr pages including my own. I can get onto my tumblr dashboard but not peoples actual blogs. Do you know what could be wrong?

5 Answers

0 votes
answered Oct 7, 2011 by Compucore (2,451 points)
Okay have you tried Clearing your cache from your web browser. And what kind of computer are you using it would definately help to give us some kind of indication of where to go for certain browsers. And which browser are you using like is it Safari, Firefox, Google Chrome, Internet Explorer, Opera. We need a little more that it is working on some web sites and not others. And have you done a Trace Route to see if there might be a problem of some sort between where you are and the web site your going too? :-)
commented Oct 8, 2011 by Zorbeen98 (311 points)
It's not the browser as i have tried different browsers. I am using a laptop running 64 bit windows 7. The websites work when i am at other peoples houses using other peoples WiFi.
0 votes
answered Oct 8, 2011 by Compucore (2,451 points)
So is it a connection problem when working with wireless at your place of residence. Or when your plugged in locally on your network. Have you even tried plugging in via wired at home and see if you get the same results with a wired connection at home??
0 votes
answered Oct 9, 2011 by Compucore (2,451 points)
OKay but this still does not answer the question. Have you tried plugging your laptop into your router or into your cable modem or dsl modem directly to see if it does the same thing as well. With a eithernet/RJ45 cable as well. To see if it does the same thing with the wired connection as well. Where some websites or other wsbsites does not come through to your laptop.
commented Oct 9, 2011 by Zorbeen98 (311 points)
Sorry i didn't see the second comment. I've just tried using a wired connection and still won't work. The websites did use to work but have suddenly stopped. :/
0 votes
answered Oct 9, 2011 by Caelan (1,656 points)
I can only think of restarting your computer, clear everything in your browser-cache , history,etc., Install a different browser because your current one could have a bug. Uninstall current browser and re-install. Hope I help.
commented Oct 9, 2011 by Zorbeen98 (311 points)
I've already tried multiple browsers :/
0 votes
answered Oct 9, 2011 by Billy Aoki (3,656 points)

Download Aimfix and Hostfix, then run those programs. And then tell me if it works.

Don't worry, I've been using them for YEARS on hundreds of PCs. Never went wrong with them.
commented Oct 9, 2011 by Zorbeen98 (311 points)
What do they do? I like to know what im doing to my pc's :p
commented Oct 9, 2011 by Billy Aoki (3,656 points)
Aimfix is a simple program to get rid of any possible hidden worms/viruses/malware that normal Antiviruses can't detect, while Hostfix resets your internet settings which may have been tampered by the malware.
commented Oct 10, 2011 by Compucore (2,451 points)
He could have gone into advanced settings in Internet explorer and reset it to factory defaults on it in there. Which does help in certain cases as well.
Welcome to Q&A, where you can ask questions and receive answers from other members of the community.