login about faq

To prove you're not a spammer, email newuser.lgqa@gmail.com with the subject "Account Request" to request an account.


For those of you who don't know, I'm running Mac OSX 10.6.6.

I have a WD 500GB USB external HDD. I plugged it in to do a backup.. and I got a read-only filesystem error. I checked 'Get Info', and it didn't give me an option to check 'write'. I went into Terminal, switched to root, went to the directory '/Volumes', and blasted it repeatedly with 'chmod 755'. It didn't work. Then I tried repairing it with Disk Utility. It didn't even give me the option of checking the disk. How can I restore write permissions to this drive?

asked Jan 10 '11 at 18:36

HHBones's gravatar image

HHBones
4.1k6182118


Did you make sure it is partitioned in something else than NTFS. I think it should be formatted in FAT 32 or for mac only exFAT)

answered Jan 10 '11 at 18:42

kevin's gravatar image

kevin ♦♦
35.8k161317591

edited Jan 10 '11 at 18:43

It is formatted as NTFS, but it's worked on my MacBook before, and I can still read from it. It's just write permissions. Should I move all the data from the drive, repartition it as FAT32, and then move all my stuff back to the drive, then backup my MacBook hard drive? Backing up my backup drive onto the drive I want to back up... how ironic...

(Jan 10 '11 at 18:45) HHBones HHBones's gravatar image

You can read NTFS, but not write NTFS (NTFS is a windows propitiatory format).

You should move the data and format the external drive

(Jan 10 '11 at 18:46) kevin ♦♦ kevin's gravatar image

Make sure you format is as Mac OS X Extended Journaled (HFS+) and it should work... Now remember this cannot be used for a Windows PC until you re-format it as Fat32 or NTFS

(Jan 11 '11 at 00:07) NickMiller NickMiller's gravatar image

NTFS is Read Only on Mac OSX. No way around it I'm afraid. I would format it as Mac OSX Journalized, FAT32 or my Personal favorite, ExFat.

answered Jan 10 '11 at 18:50

Mattophobia's gravatar image

Mattophobia ♦♦
7.0k74122206

I've decided to use FAT32. I use MacOS, Windows, and Linux. If I want compatibility, I need to use FAT32.

(Jan 10 '11 at 19:06) HHBones HHBones's gravatar image

ExFat also works on all 3 systems, yet is not limited by FAT32's 4Gb file size limit.

(Jan 10 '11 at 19:09) Mattophobia ♦♦ Mattophobia's gravatar image

I've backed up all of the files. Now one more problem. It's offering a FAT format option. I want a FAT32 format. Is there an app that can do that for me?

EDIT: Never mind. Just downloaded FHDFormatter. That should work.

answered Jan 10 '11 at 19:56

HHBones's gravatar image

HHBones
4.1k6182118

Never mind. Any suggestions?

(Jan 10 '11 at 19:57) HHBones HHBones's gravatar image

Go to a windows machine and try that

(Jan 10 '11 at 20:14) kevin ♦♦ kevin's gravatar image

The FAT option in Disk Utility is FAT32. It should work fine.

(Jan 10 '11 at 20:17) Mattophobia ♦♦ Mattophobia's gravatar image

Alright then. I'm not used to Mac formatting tools. I'm used to using Gparted after booting onto the Ubuntu Live CD. Thanks.

(Jan 10 '11 at 20:31) HHBones HHBones's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported


Tags:

×322
×243
×115
×102
×11
×9
×8

Asked: Jan 10 '11 at 18:36

Seen: 2,991 times

Last updated: Jan 11 '11 at 00:07