login about faq

To prove you're not a spammer, email newuser.lgqa@gmail.com with the subject "Account Request" to request an account.


I have an Asrock 990FX motherboard and an AMD FX-8350 CPU. I am noticing that when I put the computer to sleep, when it wakes up, the cpu cores are not clocking correctly.

I have cool and quiet disabled in bios.. (that's the setting that allows for the cpu cores to clock up and down based on load.) So..when enabled, at idle, 1.4ghz...when load..4.2ghz...and each core does this interdependently. I have this disabled, so my cores are all 4.2ghz at all times....

But when when the computer wakes from sleep..I notice (via HWiNFO64) that only 2 cores are locked at 4.2ghz and the rest are now locked at their lowest clock(1.4ghz). Only way to fix this is to reboot.

I actually experienced similar behavior on my Phenom II 1100T x6 cpu(before I upgrade to the fx)..It has done this on both Win 7 and 8.

It is, as if, the cool and quiet feature gets re-activated when you wake from sleep state...but I am not sure if this is a amd cpu thing..or a motherboard thing...or both?

Anyone else notice this issue?

asked Feb 21 '13 at 05:21

Simba's gravatar image

Simba
317810

edited Feb 21 '13 at 07:33


This could be because of the C states. Check if these settings are enabled in the bios. This lets the cpu disables certain cores to save energy.

answered Feb 21 '13 at 07:19

Cobz666's gravatar image

Cobz666
162

edited Feb 21 '13 at 07:48

I don't exactly know how some of these bios settings affects the cpu wile in use...but none of them whether enabled or disabled, seems to resolve this issue of waking from sleep. Other than having cool and quiet enabled, then the core dynamically clock up and down all the time...which I don't want anyway....also...it causes a high pitch wine from my mb when it clocks the cpu down...I am very sensitive to high pitch noises..so cool and quiet it is not ...lol.

(Feb 21 '13 at 07:33) Simba Simba's gravatar image

An alternative is putting the computer in hibernate mode instead of sleep. It takes a little longer to boot, but this should fix your problem.

(Feb 21 '13 at 09:36) Cobz666 Cobz666's gravatar image

Could you also try this:

Enable Cool and Quiet. Go to your power settings in windows, select the high performance plan, chose to edit the plan and set the cpu power saving options to 100% (min and max).

(Feb 21 '13 at 09:41) Cobz666 Cobz666's gravatar image

Cool and quite is a bios/ hardware function that over rides the settings in windows power config plans...so setting it to max cpu speed makes no difference.

(Feb 22 '13 at 00:51) Simba Simba's gravatar image

Just try it! That is the way one can override the c&q function, just the same way one can override speedstep on Intel cpu's. I know this because this is how I make the cpu always run on max in my mbp. It works...

(Feb 22 '13 at 01:44) Cobz666 Cobz666's gravatar image

"mbp"....that's why...and that's intel...not amd....and..perhaps I should have made it more clear...i did try..no effect...

(Feb 22 '13 at 05:58) Simba Simba's gravatar image

Then I'm out of suggestions. I have noticed there are more users that have the same problem with the same motherboard. They fix it by enabling c&q, setting the high performance plan and then changing the min to 100%.

(Feb 22 '13 at 09:11) Cobz666 Cobz666's gravatar image

I have tired that...even with c&q enabled....the min and max settings of windows has no effect on the cpu...and c&q should be off when overclocked anyway...which mine is..very little though..however, i did restore to stock default settings...and same issue as described.

(Feb 23 '13 at 10:44) Simba Simba's gravatar image
showing 5 of 8 show all
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported


Tags:

×236
×177
×75
×23

Asked: Feb 21 '13 at 05:21

Seen: 799 times

Last updated: Feb 23 '13 at 10:44