login about faq

To prove you're not a spammer, email newuser.lgqa@gmail.com with the subject "Account Request" to request an account.


I would like to be able to put a hard drive online so I can access my files anywhere I am. But my computer will not let me. I have Windows Vista Home Premium. I can access my files on the network. I've used CrossFTP Server. When I go to my network IP Address with the port, it shows a 404 error.

EDIT: I do not need help with this question anymore. The idea was canned.

This question is marked "community wiki".

asked Nov 14 '10 at 13:00

Anthony%20Guidetti's gravatar image

Anthony Guidetti
1.7k8896125

wikified Nov 18 '10 at 22:16


Do not type ftp://[myrouterip]:22 <--- because your router is not the machine your FTP is set up on. You want to type ftp://[YOUR_IP]:22. I suggest reading a book about networking before attempting to set up an FTP server.

answered Nov 14 '10 at 20:26

Seb's gravatar image

Seb
(suspended)

I don't literally mean my routers IP address. I know how to make FTP servers, I've made them successfully before.

(Nov 14 '10 at 21:34) Anthony Guidetti Anthony%20Guidetti's gravatar image

You appear to confused. You said earlier, "I am typing in ftp://[myrouterip]:22 ...". The FTP server isn't running on your router, is it? So why are you expecting it to use your routers IP? I'm assuming there are two machines on your network. Your network probably has 3 IP addresses: 2x LAN IP addresses and an external internet IP address. Have you tried connecting to ftp://localhost:22/? If you've set up port forwarding for port 22 and ftp://your_internet_ip:22/ is giving your routers' SSH interface, then consider disabling your routers' SSH interface or changing the port. I suggest not using port 22 for FTP. In most cases there's something seriously wrong with allowing external access to your routers configuration, by the way.

I shouldn't have to relay very basic networking information. None of these guys should have to, either. This is information that you could understand more quickly and thoroughly if you were to just pick up a book regarding Windows Vista networking and read it.

(Nov 15 '10 at 11:35) Seb Seb's gravatar image

Sorry, I thought lockergnome.net was for asking questions.

(Nov 17 '10 at 21:35) Anthony Guidetti Anthony%20Guidetti's gravatar image

have you set up port forwarding on your router? what network address are you typing in? the one of your router? or you external ip? if you have set up port forwarding and are using your external ip then it should work.

answered Nov 14 '10 at 13:02

Tim%20Fontana's gravatar image

Tim Fontana
16.4k148211390

I am typing in ftp://[myrouterip]:22 because I set it to port 22. The problem is I can't get to it on my network. I have port forwarded.

(Nov 14 '10 at 13:11) Anthony Guidetti Anthony%20Guidetti's gravatar image

try and connect on filezilla, i never managed to get ftp:// whatever working

(Nov 14 '10 at 13:19) Tim Fontana Tim%20Fontana's gravatar image

You need to go on to your router settings and designate the port 22 (FTP port) to the computer it's running off and then it should be fine.

If you go to http://portforward.com/ and then select your router and then the service you should be all set :D

answered Nov 14 '10 at 13:29

Timn96's gravatar image

Timn96
4.7k133294

No, I mean I cannot access the FTP server in my browser AT ALL. I have port forwarded, I think it's a problem with my computer.

(Nov 14 '10 at 19:53) Anthony Guidetti Anthony%20Guidetti's gravatar image

what software are you using? i had FileZilla Server running on my server in my home office as it's the only machine that is on 24/7. and you will need to go into your router and configure that correctly to get it working. i no longer use FileZilla anymore as it's hosted on my personal cloud network.

answered Nov 15 '10 at 11:07

coolsecretspy's gravatar image

coolsecretspy
5567915

FileZilla is ace.

(Nov 15 '10 at 11:44) Database Database's gravatar image

before you try anything else first try ftp://localhost:22 or ftp://127.0.0.1:22 if that does not work there is something wrong with the configuration also make sure your firewall isnt blocking port 22 or the service that uses it.

answered Nov 15 '10 at 11:47

synaptiv's gravatar image

synaptiv
1.1k1515

Does your ISP block the port? A lot of ISPs don't like you hosting things on their residential lines. Try contacting them to figure it out.

answered Nov 17 '10 at 21:47

Liam%20Quade's gravatar image

Liam Quade
7.4k94121197

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported


Join Us in the Chat Room

Tags:

×317
×261
×35

Asked: Nov 14 '10 at 13:00

Seen: 2,178 times

Last updated: Nov 18 '10 at 22:16